Error /loader/prettify.css si usas el Plugin (Simple Code Highlighter)

No soy mucho de analizar los errores del Servidor Apache… pero de vez en cuando, es bueno revisarlo aunque el Blog Personal funcione correctamente.

En este caso en particular, me he fijado que tengo más de 300 errores diarios, cuando el Servidor Apache intenta encontrar el archivo “/loader/prettify.css”.

Como buen usuario, he buscado información sobre este css en Google y encontré, que si tienes el plugin Simple Code Highlighter  instalado en WordPress, ¡este error comienza aparecer!

Primer Test:

En mi caso, esa condición sucede al tener instalado dicho plugin, Entonces,  pruebo a des-habilitarlo durante mas de una semana y verifico que realmente este error ha desaparecido.

Solución al problema:

Como la información que había leído era correcta, procedo a aplicar la solución que a continuación os muestro.

La información la he encontrado en la página Web de Soporte de WordPress. En este Link, podrás ir al post donde he obtenido la solución.

Tendremos que editar el archivo pretty.js que está ubicado en  /wp-content/plugins/simple-code-highlighter/js/pretty.js y buscaremos:

A.push("loader/prettify.css');

Una vez encontrado, lo sustituiremos por la URL completa “en duro”

A.push("https://www.valero-torres.es/wp-content/plugins/simple-code-highlighter/js/loader/prettify.css");

Importante: Si hacéis copia y pega del código, cambiar el dominio por el vuestro.

Una vez aplicado el cambio sobre el archivo, dejamos un par de días como prueba y verificamos que el log del Servidor Apache, ya no muestra este error. 🙂